В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
muraitovaayana2
muraitovaayana2
29.10.2022 12:02 •  Информатика

Напишите программу, в которой осуществляется ввод целых чисел (ввод осуществляется пока не будет введен ноль) и подсчет суммы и среднего арифметического введённых положительных чисел. Используйте оператор repeat. Выполните тремя с разных циклов. ​

Показать ответ
Ответ:
45Эвлария
45Эвлария
13.02.2022 10:44

Без компьютера представить современный мир невозможно. Ровно так же как компьютер без клавиатуры. Без нее ввести какие - либо данные, а так же полноценно управлять совершаемыми операциями будет невозможно.

Клавиатура находится в постоянном взаимодействии с пользователем, именно от нее будет зависеть процесс работы с техникой. На сегодняшний день существует огромное многообразие клавиатур, различающиеся как по внешнему виду, так и по ряду характеристик. Как не стараются современные ученые изобрести другую форму управления и ввод данных, пока это можно осуществить только при данного устройства.

Клавиатура представляет из себя - панель с многочисленными клавишами, каждая имеет свое назначение. Нажимая на необходимую внутри происходит сложный процесс итогом, которого станет посылаемый импульс, компьютер в свою очередь его обрабатывает и в дальнейшем исполняет задачу, конечный результат можно увидеть на экране.

Клавиши на клавиатуре делятся на несколько категорий:

стандартный алфавит и цифры;

клавиши с определенным функционалом, например F;

вс клавиши (переход на заглавные буквы, перемещение курсора, листание страницы и т.д.)

Клавиатуры бывают – мембранными, наполовину механическими, полностью механическими и герконовыми.

Мембранная, подойдет тем, кто любит частенько кушать за работой, благодаря нажатию мембрана смыкается и защищает от попадания ненужных веществ. Но есть и недостаток верхний слой быстро стирается.

Полумеханическая такой защитой как мембранная не обладает, но будет служить намного дольше, так как внутренние контакты надежно защищены.

Механика не так далеко ушла, различие лишь в металлической пружинке. Сломать которую крайне сложно, а значит долгий срок службы обеспечен.

Герконовые – это последнее слово техники, в процессе их изготовления применяются последние разработки, а именно использование внутри вакуумных элементов, с одной стороны они долговечны. А с другой, очень удобны в нажатии. Но минус заключается в том, что порой рядом расположенные вещи могут вырабатывать поля, которые клавиатура тонко улавливает, т.е. может произойти операция, которую не совершали.

Клавиатуры так же могут иметь различия в длине хода, чем больше, тем дольше придется ждать отклик. Но и короткий не всегда удобен, так часто выполняются ложные операции ввиду случайного нажатия. Тут все индивидуально и каждый пользователь должен подобрать клавиатуру под себя. Есть не большие расхождения по расположению клавиш, в основном базовых.

Некоторые производители, заботясь о своих клиентах, продумывают форму клавиатуры, она может быть дугообразной и при этом иметь специальное место для отдыха рук. Интересно, но не всегда удобно, она более громосткая – раз, тяжело искать нужную клавишу – два. Есть так же клавиатуры с дополнительными кнопками упрощающие процесс работы, например кнопка «пуск», есть варианты с будильником, редко, но можно найти с интернет – кнопками.

Большей популярностью пользуется беспроводные клавиатуры, они не занимают много места за счет отсутствия провода, вообще минимизация занимаемого пространства - сейчас проблема номер один, многие стараются сделать клавиатуру меньше за счет уменьшения каймы.

Подводя итог можно отметить, что выбор клавиатуры – процесс ответственный, необходимо заранее определится для каких целей она нужна и среди сотни разных выбрать именно ту которая сделает процесс работы максимально комфортным.

0,0(0 оценок)
Ответ:
polinasenotova
polinasenotova
24.01.2020 16:26

#include <iostream>

#include <cmath>

#include <Windows.h>

using namespace std;

int main()

{

   SetConsoleCP(65001);

   SetConsoleOutputCP(65001);

   float x, y;

   cout << "Input X: ";

   cin >> x;

   cout << "Input Y: ";

   cin >> y;

   if(sqrt(x * x + y * y) < 1 || abs(x) > 1 || abs(y) > 1){

       cout << "Точка вне области";

       }

   else if( (x > 0 && y > 0) || (x < 0 && y < 0))

       cout << "Точка внутри заштрихованной области";

   else

       cout << "Точка вне области";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота