В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите программу, в которой создается список из нескольких элементов и потом этот список выводится на печать в виде таблички индекс – значение

питон

Показать ответ
Ответ:
kiryushadautovp00tv7
kiryushadautovp00tv7
26.08.2021 15:23

№1

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№2

a = [int(input('Введите значение: ')) for _ in range(int(input('Введите кол-во значений: ')))]

a.reverse()

for i in range(len(a)):

   print('индекс ', i, ', значение ', a[i], sep='')

№3

import random

print([random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))])

№4

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

№5

import random

a = [random.randrange(10, 1000) for _ in range(int(input('Введите кол-во покупок: ')))]

print(a)

print('Выручка составляет', sum(a), 'рублей')

print('Сумма наибольшей покупки составляет', max(a), 'рублей')

print('Сумма наименьшей покупки составляет', min(a), 'рублей')

№6

import random

a = [random.randrange(1, 50) for _ in range(int(input('Введите кол-во покупок: ')))]

print('')

print('| Число | Сумма от 1 до числа |')

for i in range(len(a)):

   print('')

   print('|', a[i], ' | ', sum(range(1, a[i]+1)), ' |')

print('')

Тут можно поиграть с таблицей, чтобы было хорошо было видно, а значения верные.

№7

import random

a = [random.randrange(1, 100) for _ in range(random.randrange(10, 20))]

b = int(input('Введите ограничение: '))

q = []

print(a)

for i in a:

   if i < b:

       q += [i]

print(q)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота