В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ilnitskiy
ilnitskiy
26.01.2023 05:36 •  Информатика

Напишите программу, в которой вводится число. Требуется вывести его так, что бы составляющие его цифры шли в обратном порядке. Например, вводится число 4096, надо вывести 6904. (Примичание: используйте условие внутри тела цикла, mod и div)

На вход: 123 7354
На выход 321 4537 ​

Показать ответ
Ответ:
drakula13055
drakula13055
17.02.2022 18:48
Static class Program
{
    public static IEnumerable<uint> Digits(this uint X, bool Reverse = true)
    {
        do { yield return X % 10; } while ((X /= 10) != 0);
    }

    static uint ToUnsignedInt32(this IEnumerable<uint> Digits)
    {
        return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
    }

    static void Main()
    {
        Console.WriteLine(
            uint.Parse(Console.ReadLine())
                .Digits()
                .Where(d => d % 2 == 1)
                .ToUnsignedInt32());
                
        Console.ReadKey();
    }
}
0,0(0 оценок)
Ответ:
Xzxzxzxzxzzxzxz
Xzxzxzxzxzzxzxz
27.08.2022 09:27

Название "алгоритм" произошло от латинской формы имени величайшего среднеазиатского математика Мухаммеда ибн Муса ал-Хорезми (Alhorithmi), жившего в 783—850 гг. В своей книге "Об индийском счете" он изложил правила записи натуральных чисел с арабских цифр и правила действий над ними "столбиком", знакомые теперь каждому школьнику. В XII веке эта книга была переведена на латынь и получила широкое рас в Европе.

Человек ежедневно встречается с необходимостью следовать тем или иным правилам, выполнять различные инструкции и указания. Например, переходя через дорогу на перекрестке без светофора надо сначала посмотреть направо. Если машин нет, то перейти полдороги, а если машины есть, ждать, пока они пройдут, затем перейти полдороги. После этого посмотреть налево и, если машин нет, то перейти дорогу до конца, а если машины есть, ждать, пока они пройдут, а затем перейти дорогу до конца.

В математике для решения типовых задач мы используем определенные правила, описывающие последовательности действий. Например, правила сложения дробных чисел, решения квадратных уравнений и т. д. Обычно любые инструкции и правила представляют собой последовательность действий, которые необходимо выполнить в определенном порядке. Для решения задачи надо знать, что дано, что следует получить и какие действия и в каком порядке следует для этого выполнить. Предписание, определяющее порядок выполнения действий над данными с целью получения искомых результатов, и есть алгоритм.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота