В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
thenoname1105
thenoname1105
12.11.2021 21:04 •  Информатика

Напишите программу,в которой вводятся четыре числа ( длины четырёх отрезков ). выведите "да" если из отрезков можно составить прямоугольник инче выведите "нет"

Показать ответ
Ответ:
SMAYLITOP
SMAYLITOP
27.05.2020 22:54

program ugol;

var a,b,c,f:integer;

begin

writeln('Введите шширину');

readln(a);

readln(b);

writeln('Введите длину');

readln(c);

readln(f);

if (a<>b) or(c<>f)then

writeln('Нет')

else

if (a=b)and(c=f) then

writeln('Да');

end.

(Исправленая версия)

ps(затупил подумал что квадрат это прямоугольник)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота