В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
з1з1
з1з1
03.03.2021 21:50 •  Информатика

Напишите программу в pascal для этой : найти среднее арифметическое и сумму последовательности положительных чисел

Показать ответ
Ответ:
buli4ka
buli4ka
06.10.2020 01:21
Var a, sum, i : integer; s, x : string; sa : real;
begin sum:=0; readln(s); for i:=1 to length(s) do begin x:=copy(s, i, 1); val(x, a); sum:=sum+a; end; sa:=sum/(length(s)); writeln('сумма: ', sum); writeln('среднее арифметическое: ', sa:4:2);end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота