В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kmamsmajfkf
Kmamsmajfkf
28.04.2022 19:51 •  Информатика

Напишите программу в pascalabc которая на вход получает 3 вещественных числа и выводит на экран большее из них.

Показать ответ
Ответ:
ALEXANDER982
ALEXANDER982
02.10.2020 05:02
Var 
x,y,z:real;
begin
writeln('Введите три числа');
read(x,y,z);
If (x>z) and (x>y) then
writeln('Наибольшее= ',x);
If (y>z) and (y>x) then
writeln('Наибольшее= ',y);
If (z>x) and (z>y) then
writeln('Наибольшее= ',z);
If (z=y) and (y=x) then writeln('Все числа одинаковые') else
begin
If (z=x)  then writeln('числа x и z равны');
If (y=x)  then writeln('числа x и y равны');
If (z=y)  then writeln('числа y и z равны');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота