Напишите программу в pascalabc с которой рисуется движущийся рисунок (должно двигаться не менее трех частей) , например - машина с вращающимися колесами, с цикла for и простых команд (использовать graphabc).
(АСУ) , совокупность математических методов, технических средств (ЭВМ, средств связи, устройств отображения информации и т. д.) и организационных комплексов, обеспечивающих рациональное управление сложным объектом (процессом) в соответствии с заданной целью. АСУ состоит из основы и функциональной части. В основу входят информационное, техническое и математическое обеспечение. К функциональной части относят набор взаимосвязанных программ, автоматизирующих конкретные функции управления (планирование, финансово-бухгалтерскую деятельность и др.). Различают АСУ объектами (технологическими процессами - АСУТП, предприятием - АСУП, отраслью - ОАСУ) и функциональными автоматизированными системами, напр., проектирования, расчетов, материально-технического и др. обеспечения.
C# int n = Convert.ToInt32(Console.ReadLine()); int max = 0; int index = -1; int [] mass = new int [n]; Random rnd = new Random();
for (int i = 0; i< mass.Length; i++) { mass[i] = rnd.Next(); Console.WriteLine(mass[i] + " "); }
for (int i = 0; i < mass.Length; i++) { if (mass[i] > max) { max = mass[i]; index = i; } } Console.WriteLine("Индекс наибольшего равен " + index);
короч просто описываю что надо: 1) Заводишь переменные для максимума и индекса 2) Заполняешь массив рандомными числами 3) выводишь массив 4) пробегаешь по массиву, сверяя элементы с максимумом - если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента 5) выводишь индекс элемента
в коде все понятно будет, я думаю но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.
(АСУ) , совокупность математических методов, технических средств (ЭВМ, средств связи, устройств отображения информации и т. д.) и организационных комплексов, обеспечивающих рациональное управление сложным объектом (процессом) в соответствии с заданной целью. АСУ состоит из основы и функциональной части. В основу входят информационное, техническое и математическое обеспечение. К функциональной части относят набор взаимосвязанных программ, автоматизирующих конкретные функции управления (планирование, финансово-бухгалтерскую деятельность и др.). Различают АСУ объектами (технологическими процессами - АСУТП, предприятием - АСУП, отраслью - ОАСУ) и функциональными автоматизированными системами, напр., проектирования, расчетов, материально-технического и др. обеспечения.
int n = Convert.ToInt32(Console.ReadLine());
int max = 0;
int index = -1;
int [] mass = new int [n];
Random rnd = new Random();
for (int i = 0; i< mass.Length; i++)
{
mass[i] = rnd.Next();
Console.WriteLine(mass[i] + " ");
}
for (int i = 0; i < mass.Length; i++)
{
if (mass[i] > max)
{
max = mass[i];
index = i;
}
}
Console.WriteLine("Индекс наибольшего равен " + index);
короч просто описываю что надо:
1) Заводишь переменные для максимума и индекса
2) Заполняешь массив рандомными числами
3) выводишь массив
4) пробегаешь по массиву, сверяя элементы с максимумом
- если max меньше элемента, то присваиваешь ему элемент и запоминаешь в index номер элемента
5) выводишь индекс элемента
в коде все понятно будет, я думаю
но я думаю вам нужен паскаль, но на паскале я не могу с массивами, не люблю я их.