В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
linaangel20012
linaangel20012
03.02.2020 09:58 •  Информатика

Напишите программу в паскаль, которая получает день и номер месяца, а выводит количество дней, оставшихся до нового года. считайте, что год невисокосный (365 дней). учтите, что слово "дней" может иметь также формы "день" и "дня". пример: введите день и месяц: 25 12 осталось 7 дней до нового года. пример: введите день и месяц: 1 1 осталось 364 дня до нового года. пример: введите день и месяц: 31 2 неверная дата.

Показать ответ
Ответ:
doda4i
doda4i
03.10.2020 08:43
//PascalABC
Uses System;
var day, month: integer;
begin
  Read(day, month);    var d := new DateTime(DateTime.Now.Year, month, day);    var new_year := new DateTime(d.Year+1, 1, 1);    Writeln((new_year - d).TotalDays);  end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота