В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Aminka26
Aminka26
21.04.2022 07:19 •  Информатика

Напишите программу в паскале abc, которую вводим последовательность целых чисел заканчивающуюся нулем и определяет верно ли что введеные элементы чередуют знаки, например (2, -2, 3, -3, 4, -4, 5, -5: да знаки чередуются) не используя масивов. либо объясните алгоритм действий

Показать ответ
Ответ:
alial1
alial1
31.08.2020 01:39
Program lol(input, output); var b, a, a1:integer; begin a:=1; b:=0; a1:=-1; repeat begin read (a); if (a/((-1)*a))=(a1/a1) then b:=b+1; if a=0 then break; read (a1); if a <> (-1)*a1 then b:=b+1; end until (a=0) or (a1=0); if b>1 then writeln ('Последовательность не верна') else writeln ('Последовательность верна'); end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота