Напишите программу в паскале, которая получает три числа и выводит количество натуральных одинаковых чисел в этой цепочке. пример: введите три чила: 5 5 5 все числа одинаковые.
Если в три переменные: var a,b,c:integer; begin writeln ('Введите 3 числа'); read (a,b,c); if (a=b)or (a=c) or (b=c) then begin if (a>1) and (b>1) and (c>1)and (a=b) and (a=c) and (b=c) then //Одно ненужное условие для наглядности writeln ('Все числа одинаковые'); if ((a>1) and (b>1) and (a=b)) or ((a>1) and (c>1) and (a=c)) or ((b>1) and (c>1) and (b=c)) then writeln (2); end else writeln ('Нет одинаковых чисел'); end.
var a,b,c:integer;
begin
writeln ('Введите 3 числа');
read (a,b,c);
if (a=b)or (a=c) or (b=c) then
begin
if (a>1) and (b>1) and (c>1)and (a=b) and (a=c) and (b=c) then //Одно ненужное условие для наглядности
writeln ('Все числа одинаковые');
if ((a>1) and (b>1) and (a=b)) or ((a>1) and (c>1) and (a=c)) or ((b>1) and (c>1) and (b=c)) then writeln (2);
end
else writeln ('Нет одинаковых чисел');
end.