В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
лера23451
лера23451
15.10.2022 08:49 •  Информатика

Напишите программу в паскале по условию даны действительные числа x,y. если х,у отрицательны, то каждое значение заменить его модулем; если отрицательное только одно из них, то оба значения увеличить на 27; если оба значения не отрицательны, то оба значения уменьшить на 20.

Показать ответ
Ответ:
юля2720
юля2720
03.07.2020 23:28
Var x,y:real;
begin
read (x,y);
if (x<0) and (y<0) then writeln (abs(x),' ',abs(y)) else
if ((x<0) and (y>=0)) or ((y<0) and (x>=0)) then writeln (x+27,' ',y+27) else
if (x>=0)and (y>=0) then writeln (x-20,' ',y-20);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота