Напишите программу в паскале проверки устного счета - с сколько будет два плюс три,если клиент отвечает пять,высказываем одобрение,если не пять - выносим порицание
var a:array [1..5] of integer; i:integer;begin randomize; for i:=1 to 5 do begin a[i]:=random(31)-15; write (a[i]:4); end; writeln; for i:=1 to 5 do begin a[i]:=a[i]*2; write (a[i]:4); end; writeln; readln;end.C++:#include <iostream>#include <ctime>#include <cstdlib>using namespace std;int main(){ int a[5]; srand (time(NULL)); for (int i = 0; i<5; i++) { a[i] = rand()%15-15; cout <<a[i] <<" "; } cout <<endl; for (int i = 0; i<5; i++) { a[i]*=2; cout <<a[i] <<" "; } return 0;
Правильный ответ: 7 Ты из пункта А в пункт B едешь 2км. Из B в пункт E 5км.
То есть куда тебе нужно из серой клетки попасть в другую серую. Например из А в пункт B, ты уже проехал 2км. Далее смотришь по горизонтали куда можно поехать. Ты видишь 3км (в столбике С) и 5км (в столбике E). Например выбираешь С и спускаешь на серую клетку. Далее от неё смотришь 6 (столбик D) и 10 (столбик E). Дальше так же выбираешь и спускаешься, но это я на пример показал длинный путь. Самый кратчайший я написал под правильным ответом. Надеюсь понятно объяснил, если что пиши в комментариях или в сообщения.
var a:array [1..5] of integer; i:integer;begin randomize; for i:=1 to 5 do begin a[i]:=random(31)-15; write (a[i]:4); end; writeln; for i:=1 to 5 do begin a[i]:=a[i]*2; write (a[i]:4); end; writeln; readln;end.C++:#include <iostream>#include <ctime>#include <cstdlib>using namespace std;int main(){ int a[5]; srand (time(NULL)); for (int i = 0; i<5; i++) { a[i] = rand()%15-15; cout <<a[i] <<" "; } cout <<endl; for (int i = 0; i<5; i++) { a[i]*=2; cout <<a[i] <<" "; } return 0;
Объяснение:
Ты из пункта А в пункт B едешь 2км.
Из B в пункт E 5км.
То есть куда тебе нужно из серой клетки попасть в другую серую. Например из А в пункт B, ты уже проехал 2км. Далее смотришь по горизонтали куда можно поехать. Ты видишь 3км (в столбике С) и 5км (в столбике E). Например выбираешь С и спускаешь на серую клетку. Далее от неё смотришь 6 (столбик D) и 10 (столбик E). Дальше так же выбираешь и спускаешься, но это я на пример показал длинный путь. Самый кратчайший я написал под правильным ответом.
Надеюсь понятно объяснил, если что пиши в комментариях или в сообщения.