Для какого наименьшего целого неотрицательного числа А выражение
(3x + 5y < A) ∨ (x ≥ y) ∨ (y > 8)
тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?
Решение.
Решим задачу графически. Условия (x ≥ y) и (y > 8) задают множество, отмеченное на рисунке закрашенной областью. Чтобы исходное выражение было тождественно истинно для любых целых и неотрицательных x и y, прямая 3x + 5y = A должна проходить выше точки (8; 7). Таким образом, наименьшее целое неотрицательное А, удовлетворяющее условию задачи — это A равное 62.
Приведем аналитическое решение.
Если истинно одно из выражений (x ≥ y) или (y > 8), то выражение (3x + 5y < A) ∨ (x ≥ y) ∨ (y > 8) истинно независимо от значения А.
Если же оба выражения (x ≥ y) и (y > 8) ложны, то есть при выполнении условий (x < y) и (y ≤ 8), выражение 3x + 5y < A должно быть истинным.
Найдем максимально возможное значение выражения 3x + 5y при выполнении условий (x < y) и (y ≤ 8).
Заметим, что для целых чисел неравенство (x < y) равносильно неравенству (x ≤ y-1). Тогда
3x+5y ≤ 3(y-1) + 5y = 8y – 3 ≤ 64 – 3 = 61.
Таким образом, должно выполняться условие 61<А, откуда А=62.
Для какого наименьшего целого неотрицательного числа А выражение
(3x + 5y < A) ∨ (x ≥ y) ∨ (y > 8)
тождественно истинно, т. е. принимает значение 1 при любых целых неотрицательных x и y?
Решение.
Решим задачу графически. Условия (x ≥ y) и (y > 8) задают множество, отмеченное на рисунке закрашенной областью. Чтобы исходное выражение было тождественно истинно для любых целых и неотрицательных x и y, прямая 3x + 5y = A должна проходить выше точки (8; 7). Таким образом, наименьшее целое неотрицательное А, удовлетворяющее условию задачи — это A равное 62.
Приведем аналитическое решение.
Если истинно одно из выражений (x ≥ y) или (y > 8), то выражение (3x + 5y < A) ∨ (x ≥ y) ∨ (y > 8) истинно независимо от значения А.
Если же оба выражения (x ≥ y) и (y > 8) ложны, то есть при выполнении условий (x < y) и (y ≤ 8), выражение 3x + 5y < A должно быть истинным.
Найдем максимально возможное значение выражения 3x + 5y при выполнении условий (x < y) и (y ≤ 8).
Заметим, что для целых чисел неравенство (x < y) равносильно неравенству (x ≤ y-1). Тогда
3x+5y ≤ 3(y-1) + 5y = 8y – 3 ≤ 64 – 3 = 61.
Таким образом, должно выполняться условие 61<А, откуда А=62.
ответ: 62.
Объяснение:
#include <iostream>
#include <regex>
#include <fstream>
#include <string>
using namespace std;
int main() {
ifstream fin("f");
string s = "", _temp;
while (getline(fin, _temp))
s += _temp;
fin.close();
ofstream fout("g");
try {
regex re("[a-z]");
sregex_iterator next(s.begin(), s.end(), re);
sregex_iterator end;
while (next != end) {
smatch match = *next;
fout << match.str();
next++;
}
}
catch (regex_error& e) {
cout << "smth went wrong.";
}
fout.close();
}