В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DashaSi15
DashaSi15
03.07.2020 06:18 •  Информатика

Напишите программу в пайтоне, вычисляющую значение y=sqrt(x^2 - 1). Сделать так, чтобы черепаха рисовала график ​

Показать ответ
Ответ:
lizabelova00
lizabelova00
04.04.2022 22:27

program dimavdovuskin497;

type t1 = integer;

    t2 = double;

var n, i: t1;

   x, summa, pr: t2;

begin

writeln('Напишите программу, вычисляющую: а) сумму n первых натуральных четных чисел; б) произведение n первых натуральных нечетных чисел.');

writeln;

write('Введите общее количество чисел: ');

readln(n);

writeln;

summa := 0;

pr := 1;

for i := 1 to n do

begin

 write('Введите х: ');

 readln(x);

 writeln;

 if (frac(x) = 0) then

 begin

  if (frac(x/2) = 0) then summa := summa + x

   else pr := pr * x;

 end;

end;

writeln('Сумма n первых натуральных четных чисел равна ', summa : 5 : 0);

writeln;

writeln('Произведение n первых натуральных нечетных чисел равно', pr : 5 : 0);

readln;

end.

0,0(0 оценок)
Ответ:
bisenkoda
bisenkoda
15.03.2023 13:09

Правила организации личной информации в сети Интернет

старайтесь не заполнять анкеты данных в неизвестных чатах, социальных сетях,

не оставляйте встреченным в Интернете людям свой номер телефона, домашний адрес,

не отправляйте неизвестным людям свои фотографии,

общайтесь в программах Skype и им подобным только с друзьями,

не открывайте прикрепленные к письму файлы, полученные от незнакомых людей,

не разглашайте информацию о своем пароле

Правила безопасности в сети Интернет

не договаривайтесь о встрече с незнакомцами,

не отвечайте на недоброжелательные сообщения,

выходите из чата, если чье-то сообщение вызывает беспокойство,

будьте внимательны при загрузке бесплатных программ на компьютер,

если вы получили оскорбляющее сообщение, сообщение о нем родителям,

не поддавайтесь на заманчивые предложения,

не посещайте сайты для взрослых

Правила сетевого этикета

старайтесь выглядеть достойно в глазах собеседников,

пишите грамотно,

человек, с которым вы общаетесь, может быть не один,

сдерживайте страсти,

будьте терпимы к недостаткам окружающих

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота