В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
BazikPro
BazikPro
06.04.2022 22:14 •  Информатика

Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.

Показать ответ
Ответ:
alonsoqureaz
alonsoqureaz
15.10.2020 12:39

вот.............................

Объяснение:

k=0

i=0

x=int(input())

while x!=0:

if x%3==0 and x%2>0:

 k+=1

x=int(input())

i+=1

print(i)

print(k)


Напишите программу в ПИТОНЕ, которая в последовательности целых чисел определяет количество нечётных
0,0(0 оценок)
Ответ:
ekatsinrom
ekatsinrom
15.10.2020 12:39

import typing

from typing import Callable

def ReadSeqWhile(SeqType, predicate: Callable[[int], bool]):

   temp = SeqType(input())

   while predicate(temp):

       yield temp

       temp = SeqType(input())

def main():

   RawSequence = ReadSeqWhile(int, lambda x: x != 0)

   Selector = lambda item: (item % 3 == 0) and (item % 2 != 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Число элементов, удовлетворяющих условию: {len( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота