В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ale2005171112
ale2005171112
26.08.2020 12:14 •  Информатика

Напишите программу в Python-е, которая вoзвращает рeзультат цeлочисленного и по модулю дeления любого цeлого числa нa -17

Показать ответ
Ответ:
KllaBer
KllaBer
12.10.2022 20:51

1) ответ: 12

a 1 2 3

b 1 2 4

2) ответ: i = 30

3) ответ: б), потому что условие проверяется перед началом работы очередного круга цикла.

3 (???) ) ответ: 2 раза. В ходе работы цикла переменная p должна стать равной 0.02

4) ответ: г)

Какое тут должно быть объяснение? Всё прекрасно видно, если посмотреть на саму задачу! Сначала i равен нулю, потом ему прибавляется в значении по единице, пока i не станет равным пяти (0,1,2,3,4,5). Итого к S прибавляется единица шесть раз.

Снизу практически анологично. Это максимально тупо, что просите объяснения к таким простым вопросам.

5) ответ: г)

Какое тут должно быть объяснение? Всё прекрасно видно, если посмотреть на саму задачу! Сначала i равен -1, потом ему прибавляется в значении по единице, пока i не станет равным 2 (-1,0,1,2). Итого к S прибавляется единица 4 раза.

0,0(0 оценок)
Ответ:
qpdgjekelxnvi
qpdgjekelxnvi
19.01.2023 03:07
Заменить нечётные элементы по значению

program  raf105;

var  

 a:array[1..20] of integer;

 i,min: integer;

begin

min:= 10000;

writeln('Исходный массив:');

for i:=1 to 20 do

begin

 a[i]:= random(-30,20);

 writeln(a[i]);

 if a[i]<min

   then min:= a[i];

end;

writeln('Изменённый массив:');

for i:=1 to 20 do

begin

 if (a[i] mod 2)<>0

   then a[i]:= min;

 writeln(a[i]);

end;

end.

Заменить нечётные элементы по индексу

program  raf105;

var  

 a:array[1..20] of integer;

 i,min: integer;

begin

min:= 10000;

writeln('Исходный массив:');

for i:=1 to 20 do

begin

 a[i]:= random(-30,20);

 writeln(a[i]);

 if a[i]<min

   then min:= a[i];

end;

writeln('Изменённый массив:');

for i:=1 to 20 do

begin

 if (i mod 2)<>0

   then a[i]:= min;

 writeln(a[i]);

end;

end.

Язык PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота