В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
khsush
khsush
18.02.2021 00:10 •  Информатика

Напишите программу в Python В детском садике n детей играют в следующую игру. Перед ними гора из m
кубиков, первый ребёнок вынимает из кучи 1 кубик, каждый последующий
ребёнок — в два раза больше предыдущего и так по кругу. Если число кубиков, которые нужно вынуть, превышает 25, из него вычитается 25 и отсчёт
идёт от уменьшенного числа, например, вместо 32 кубиков будет вынуто 7,
затем 14 и т. д. Проигравшим считается тот, кто не смог вытащить нужное
число кубиков (в куче осталось недостаточно). Определите проигравшего.

Показать ответ
Ответ:
alins3
alins3
03.05.2023 18:30

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Ответ:
1234567890dd
1234567890dd
27.08.2022 00:29
1)
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;   
max:=0;
while n>0 do 
begin 
m:=n mod 10; 
if m<min then min:=m; 
if m>max then max:=m; 
n:=n div 10; end;   
writeln('Максимальное число: ',max);   
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота