В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
LoveSmile78900987
LoveSmile78900987
06.04.2021 21:50 •  Информатика

Напишите программу в результате которой первое введеное число уменьшается в 2 раза, если оно больше третьего, а третье разностью третьего и второго, если оно больше второго! на языке паскаль

Показать ответ
Ответ:
Anna66613
Anna66613
07.10.2020 19:59
Var
a,b,c:real;
begin
Readln(a,b,c);
if a > c then a:= a/2;
if c > b then c:= c-b;
Writeln(a, ' ', b, ' ', c);
end.

Пример:
4 2 3
2 2 1
0,0(0 оценок)
Ответ:
ksusha00008
ksusha00008
07.10.2020 19:59
Var
x,y,z:real;
begin
write('Введите 1 число: ');
readln(x);
write('Введите 2 число: ');
readln(y);
write('Введите 3 число: ');
readln(z);
if x>z then x:=x/2;
if z>y then z:=z-y;
writeln('1 число: ',x);
writeln('2 число: ',y);
writeln('3 число: ',z);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота