В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Арсенал11
Арсенал11
26.10.2022 19:39 •  Информатика

Напишите программу вычисления площади кольца, радиусы вводятся с клавиатуры. используйте функцию вычисления площади круга

Показать ответ
Ответ:
NiKoOl18
NiKoOl18
05.10.2020 14:33
Var r1,r2,s:real;
function square(r:real):real;
begin
square:=pi*r*r;
end;
begin
writeln('r1, r2:');
readln(r1,r2);
s:=abs(square(r1)-square(r2));
writeln('Площадь кольца = ',s:5:2);
end.

Пример:
r1, r2:
3 5
Площадь кольца = 50.27
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота