Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
moiytrewq20005
13.01.2020 06:34 •
Информатика
Напишите программу вычисления суммы факториалов всех нечетных чисел от 1 до 9 (паскаль)
Показать ответ
Ответ:
ukubasov
12.07.2020 07:26
Var n, i: integer;
function fact(n: integer): integer;
begin
if n = 1
then
fact := 1
else
fact := fact(n - 1) * n;
end;
begin
for i := 1 to 9 do
if i mod 2 = 1
then
writeln(fact(i));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
urazukov
04.03.2022 13:05
24 бита в байты 4 килобайта в байты : )...
vecronika54
04.09.2021 18:21
Дано целое число ,не меньшее 2.вывести сколько делителей у этого числа. в паскале решение для 8класса...
Nikoletta2550
04.09.2021 18:21
Составьте таблицу значений функции y = 5x² - 2x +1 на отрезке [-5; 5] с шагом b = 2. c for и repeat pascal...
Голубь20079
31.05.2022 20:52
Антивирусные программы, плюсы и минусы. чтобы прям так много их было. (не стоит перечислять приложения антивирусных программ, просто всеобщий расчет недостатков и плюсов)...
MariaStredinina
15.02.2021 23:15
Разрешение экрана монитора 800х480 означает,что изображение на его экране будет состоять из точек в каждой строке...
7376373
14.05.2021 13:32
На графе изображены пункты А,B,C,D,E,F,G,H,K,L и связывающие их дороги. По каждой дороге можно двигаться только в одном направлении, на которое указывает стрелка. Сколько...
coast31g2005
28.01.2023 23:09
Взаданном одномерном массиве поменять местами соседние элементы. напишите программу на паскале, заранее !...
MrMike1
28.01.2023 23:09
Файл объёмом 450 байт был скачан стандартным модулем загрузки браузера за 10 секунд .скорость скачивания равна ?...
EsMiLe1999
06.11.2021 06:09
3. Что произойдет в результате выполнения функции А) Вычисление суммы чисел, равных 15, из диапазонаБ) Сравнение чисел, больше 15, из диапазона Al:A5.В) Вычисление суммы...
Helpppppp11
28.07.2022 02:30
Запиши алгоритм действия....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
function fact(n: integer): integer;
begin
if n = 1
then
fact := 1
else
fact := fact(n - 1) * n;
end;
begin
for i := 1 to 9 do
if i mod 2 = 1
then
writeln(fact(i));
end.