В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kurbedinovazar
kurbedinovazar
20.08.2020 19:21 •  Информатика

Напишите программу вычисления суммы отрицательных значений функции q(w)=31w+31 на отрезке [a; b] с шагом h

Показать ответ
Ответ:
IvanRusYT
IvanRusYT
08.10.2020 05:56
PascalABC.NET:

Var
  Q,w, a,b,h, S: real;
Begin
  WriteLn('Q(w) = 31w+31');
  Write('a = ');ReadLn(a);
  Write('b = ');ReadLn(b);
  Write('h = ');ReadLn(h);
  S := 0;
  w := a;
  if (a < b) then
  begin
    if (h < 0) then exit;
  end
  else if (a > b) then
    if (h > 0) then exit;
 
  While (w <= b) do
  begin
    Q := 31*w+31;
    if (Q < 0 ) then
      S := S + Q;
    w := w + h;
  end;
  WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота