В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nesty111111
Nesty111111
18.01.2021 02:22 •  Информатика

Напишите программу вычисления выражения: s=1! +2! +3! ++n! 5-9 класс здесь n! - факториал числа n. n! =1*2**(n-1)*n. используйте функцию вычисления факториала.

Показать ответ
Ответ:
Shiro1303
Shiro1303
08.10.2020 10:36
//PascalABC.NET
//Версия 3.3.5, сборка 1650
begin
var f: integer->real:=x->range(1,x).Aggregate(Real(1),(a,b)->a*b);
var n:=ReadInteger('n=');
write(range(1,n).Select(x->f(x)).Sum)
end.
0,0(0 оценок)
Ответ:
Всенорм1111
Всенорм1111
08.10.2020 10:36
Var s,j,k:longint;
function f(n:byte):longint;
var f1:longint;
i:integer;
begin
if n<1 then f1:=1
else begin
f1:=1;
for i:=1 to n do
f1:=f1*i;
end;
f:=f1;
end;
begin
s:=0;
readln(k);
for j:=1 to k do
s:=s+f(j);
writeln(s);
readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота