В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Ramaz7771
Ramaz7771
28.04.2020 11:16 •  Информатика

Напишите программу, вычисляющую с использованием цикла сумму дробей от 1/ N2 до 1/(N+5) 2. Программа получает на вход число N и выводит искомую сумму. Что выведет программа при N= 5?

Показать ответ
Ответ:
denisplaver
denisplaver
07.01.2022 03:19
Цикл foruses Math;var    i: integer;    sum: real;begin    for i := 1 to 100 do        Sum := Sum + Sqr(i);    Writeln(Sum);end.Цикл while (предусловие)uses Math;var    i: integer;    sum: real;begin    while i <= 100 do        begin            Sum := Sum + Sqr(i);            i := i + 1;        end;    Writeln(Sum);end.Цикл repeat..until (постусловие)uses Math;var    i: integer;    sum: real;begin    repeat        i := i + 1;        Sum := Sum + Sqr(i);    until i >= 100;    Writeln(Sum);end.
0,0(0 оценок)
Ответ:
mikc2
mikc2
07.01.2022 03:19

Задание 1

program HelloMoney;

 var

 y, i: integer; // Объявим переменные для количества лет вклада и для счетчика цикла  

p, s: real; //Объявим переменные для количества процентов и величины вклада

begin

write('Какая сумма вклада? ');

readln(s); // Указываем сколько составляет вклад

write('На сколько лет вклад? ');

readln(y); // Указываем на сколько лет вклад

write('Какая процентная ставка?');

readln(p); // Указываем процентную ставку

for i:=1 to y do

s := s + s*p/100; // Прибавляем к вкладу ежегодный процент

write('Сумма денег составит: ', s);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота