Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
mksmsslvp0b481
20.04.2020 01:49 •
Информатика
Напишите программу, вычисляющую значение функции: у ={-1 при х< 0, у ={0 при х=0, у={1 при х> 0. пример входных данных -5 0 5 пример выходных данных у=-1 у=0 у=1
Показать ответ
Ответ:
helpmy123
08.10.2020 01:43
Var x,y: integer;
begin
readln(x);
if x<0 then y:=-1
else if x=0 then y:=0 else y:=1;
writeln('y = ',y);
end.
Пример:
-5
y = -1
0,0
(0 оценок)
Ответ:
WallyMF
08.10.2020 01:43
Язык C++.
#include
using namespace std;
int main (){
int x;
cout << "Введите x: " << endl;
cin >> x;
if(x < 0){
cout << "y = -1" << endl;
}
else if(x == 0){
cout << "y = 0" << endl;
}
else{
cout << "y = 1" << endl;
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
alinakodz11p05402
23.01.2023 19:42
Что изобразит черепашка выполнив алгоритм: повтори 8 [ направо 45, вперед 45] желательно с рассуждением...
Самозванко
12.03.2022 19:24
Запиши программу на языке Паскаль. var i,n:word; begin write( n= ); readln(n); for i:=1 to n do begin write(i, ); end; readln; end. На экране n=5 5 0 25 12345...
RETYUOP
30.05.2022 02:10
На полке было 16 книг. Ваня взял 2-ую слева. Сколько информации содержит данное сообщение? 16 бит2 байт4 бит 4 байт...
Криста02
08.09.2022 21:32
Дан массив чисел, проверить для каждого числа сколько существует в списке числе меньше данного числа и давить в другой список. Вернуть массив. Example 1: Input: nums = [8,1,2,2,3]...
ferrum4
12.11.2020 12:35
Проект для обчислення середнього арифметичного додатних чисел серед чисел, перше з яких дорівнює a=100, а кожне наступне менше від попереднього на 7...
lurudzheva
12.03.2022 15:28
1) Какие из чисел 390^8, 011011011^2, 257^10, 2D^16 можно сохранить в 8- разрядном формате? 2) Запишите следующие числа в естественной форме: а) 0,1234144∙10^3; б) 0,242∙10^-2;...
Masha6655
08.10.2020 03:33
С ИНФОРМАТИКОЙ А И Б даю...
NastysikRicci
04.06.2020 15:44
Почему северно ледовитый океан так называется...
mazeke78
04.06.2020 15:44
Іть будь-ласка розв язати з поясненням: один насос може накачати 5400л., води за 18хв.,а інший-за 9хв.за скільки хв.,накачають цю воду два насоси,працюючи разом?...
ааа516
04.06.2020 15:44
Гипотенуза прямоугольного треугольника равна 10 а проекция меньшего катета на гипотенузу 3,6 найти радиус окружности вписанной в этот треугольник...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
readln(x);
if x<0 then y:=-1
else if x=0 then y:=0 else y:=1;
writeln('y = ',y);
end.
Пример:
-5
y = -1
#include
using namespace std;
int main (){
int x;
cout << "Введите x: " << endl;
cin >> x;
if(x < 0){
cout << "y = -1" << endl;
}
else if(x == 0){
cout << "y = 0" << endl;
}
else{
cout << "y = 1" << endl;
}
}