В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
aboboskayaovrain
aboboskayaovrain
17.12.2022 11:41 •  Информатика

Напишите программу заполнения массива из 20 элементов случайными числами в диапозоне от -150 до 1000. найдите количество элементов, которые имеют нечетное значение и делятся на пять.

Показать ответ
Ответ:
sonsonms
sonsonms
19.07.2020 19:54
Var a:array[1..20] of integer;
    n,i:integer;
begin
for i:=1 to 20 do begin
  a[i]:=random(-150,1000);
  if (a[i] mod 5=0) and (a[i] mod 2<>0) then n+=1;
  write(a[i],' ');
end;
writeln();
writeln('Искомых элементов: ',n);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота