В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kulichok14
Kulichok14
16.09.2020 19:01 •  Информатика

Напишите программу, запрашивающую пин-код для банковской карты в виде четырехзначного числа. Считая, что в правильном пин-коде сумма первых двух цифр должна равняться сумме двух последних, выводя в случае ввода неправильного пин-кода соответствующее сообщение написать программу в Pascal ;(

Показать ответ
Ответ:
almaz20004
almaz20004
15.10.2020 21:01

pascal

Объяснение:

program pincode;

var

 pin: integer;

begin

 repeat

   Write('Введите PIN-код: ');

   ReadLn(pin);

 until (length(inttostr(pin)) = 4);

 if (pin div 1000 + (pin mod 1000) div 100) = ((pin mod 100) div 10 + pin mod 10)

     then WriteLn('PIN-код верен!') else WriteLn('PIN-код неверен!');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота