В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
AlinaFlowers
AlinaFlowers
04.06.2022 22:19 •  Информатика

Напишите в питоне , Алгоритм вычисления значения функции
F(n), где n – натуральное число,
задан следующими соотношениями:
F(n) = 1 при n = 1;
F(n) = n +F(n − 1), если n чётно,
F(n) = 2 * F(n − 2), если n > 1 и при этом n нечётно.
Чему равно значение функции
F(26)?

Показать ответ
Ответ:
Ульяна2732
Ульяна2732
19.01.2022 16:40

4122

Объяснение:

def F(n):

   if n == 1:

       return 1

   elif n % 2 == 0:

       return n + F(n - 1)

   else:

       return 2 * F(n - 2)

print(F(26))

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота