В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
знайка56884
знайка56884
15.12.2021 10:35 •  Информатика

Напишите в питоне , Исполнитель преобразует число на экране.
У исполнителя есть две команды, которым присвоены номера:
1. Прибавить 1
2. Умножить на 2
Программа для исполнителя – это последовательность команд.
Сколько существует программ, для которых при исходном числе 1
результатом является число 20, и при этом траектория вычислений содержит
число 10?
Траектория вычислений программы – это последовательность результатов
выполнения всех команд программы. Например, для программы 121 при
исходном числе 7 траектория будет состоять из чисел 8, 16, 17.

Показать ответ
Ответ:
ycnakouc7oy2xua
ycnakouc7oy2xua
19.01.2022 11:30

d = [0] * 21

d[1] = 1

for i in range(2, 11):

   d[i] = d[i-1]

   if i % 2 == 0:

       d[i] += d[i // 2]

for i in range(11, 21):

   d[i] = d[i-1]

   if i % 2 == 0 and i // 2 >= 10:

       d[i] += d[i // 2]

print(d[20])

ответ: 28

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота