В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Напишите в питоне Программа получает на вход число проехавших автомобилей N (1>N>30), затем указываются их скорости. Значение скорости не может быть меньше 1 и больше 300. Программа должна сначала вывести разность максимальной и минимальной скоростей автомобилей,затем количество автомобилей, скорость которых не превышала 30 км/ч. ​

Показать ответ
Ответ:
fylkis
fylkis
01.02.2022 13:09

Объяснение:

ов посимвольно в массив А[N]. Определить, является ли данное слово палиндромом (то есть одинаково читается как слева направо, так и справа налево).

C++Выделить код

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

#include <iostream>

#include <clocale>

int main()

{

setlocale(0, "");

std::cout << "Введите количество символов в слове A: n= ";

int n; // количество символов с слове

std::cin >> n;

//std::cout << "Введите символы в слове A:\n";

char* a = new char[n + 1]; // массив для символов, слово

for (int i = 0; i < n; i++)

{

std::cout << "A[" << i << "]= ";

std::cin >> a[i];

}

a[n] = '\0'; // добавляем символ конца строки

// Проверяем, является ли слово палиндромом

int i = 0;

while (i < n / 2 && a[i] == a[n - i - 1])

{

i++;

}

std::cout << "Ваше слово '" << a << "' ";

if (i == n / 2)

{

std::cout << "является палиндромом.\n";

}

else

{

std::cout << "не является палиндромом.\n";

}

// Освобождаем динамическую память

delete[] a;

system("pause");

}

0,0(0 оценок)
Ответ:
Ботакан17
Ботакан17
17.03.2021 22:31

1.) программаға сәйкес операцияларды орындауға арналған компьютердің негізгі құрылғысы, қызметтік бөлігі. Көптеген жартылай өткізгішті элементтерден тұратын және компьютерде барлық есептеулер мен ақпарат өндеу жұмыстарын орындайтын электрондық микросхема. Қазіргі компьютерлерде бір немесе бірнеше процессорлар жұмыс істейді.

2.Процессор деген компьютердегі барлық қызметті атқарып тұрған адамның миы сияқты құрылғы, арифметикалық-логикалық қызметтер атқарады. процессорды CPU американдық компаниялар Intel, AMD жасап шығарады.

ОЗУ деген қысқа мерзімге мәлімет сақтауға арналған. компьютерде жасалып жатұан операциялардың бәрң осы озуда сақталады. компьютерді өшіргенде бәрі кетіп қалады.

Материнская плата деген компаның орталық астанасы. Процессор, озу, слоттар, жесткий диск бәрң соған қосып жалғанады.

Видеокарта деген графикалық ақпараттардың қалыпты жұмыс істеуіне арналған. Видео және ойындардың графикасына жауап беретін құрылғы осы.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота