В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ymolyauy
ymolyauy
25.12.2022 10:17 •  Информатика

нарисовать блок схему по данному заданию Составить программу упорядочивания трех чисел x, y, z по возрастанию.
если что вот алгоритм программы
var x, y, z : integer;
begin
Writeln('Введите значения X Y Z: ');
Readln(x, y, z);
if x > Y then
begin
x := x + Y;
x := x - Y;
x := x - Y;
end;
if Y > Z then
begin
Y := y + z;
z := Y - z;
y := y - z;
end;
if x > y then
begin
x := x + y;
y := x - y;
x := x - y;
end;
writeln('X=',x, 'Y=',y, 'Z=',z);
end.

Показать ответ
Ответ:
yulyatalko
yulyatalko
29.03.2022 19:19
Порядок действий:
1 Отрицание-инверсия(не, обозначается - )
2Действия в скобках
3 Конъюнкция-умножение(и, обозначается&)
4 Дизъюнкция-сложение(или, обозначается галочкой)
истина-1,ложь-0 
например:
1галочка0&1 следуя по всем законам математики, сначала выполняется умножение т.е & значит 0*1=0, а затем выполняем сложение(галочка) 1+0=1 следовательно ответ истина
1) 1&0=0-ложь
2)1 галочка0=1-истина
3) не 1 галочка 0 - 0+0=0-ложь
4)1 & 0 галочка 1=1*0+1= 1-истина
5)1 галочка 0&1=1+0*1=1-истина
 6)не1 галочка 0 &1=0+0*1=0-ложь
7)(1галочка0) &(1галочка0)=(1+0)*(1+0)=1*1=1-истина
8)не(1галочка0) & (1галочка0)=не(1+0)*(1+0)=не1* 1=0*1=0-ложь
9)не(1&0&1)=не(1*0*1)=не(0*1)=не0=1-истина
0,0(0 оценок)
Ответ:
mohob
mohob
26.03.2023 20:02

#include <iostream>

#include <conio.h>

using namespace std;

void main()

{

       setlocale(LC_ALL, "Russian");

system("title Материалы");

       system("color 74");

       int material;

       start:

       system("CLS");

       cout << "Введите число для уточнение названия детали:\n";

       cin >> material;

       switch (material)

       {

       case 1: cout <<"Шуруп\n";

             break;

       case 2: cout<<"Гайка\n";

             break;

       case 3: cout<<"Винт\n";

             break;

             case 4: cout<<"Гвоздь\n";

             break;

             case 5: cout<<"Болт\n";

             break;

             default: cout<<"Предмет не найден\n";

                    break;

       }

                    getch();

       goto start;

       }

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота