Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
valya83
04.07.2021 09:45 •
Информатика
Найдите количество элементов массива, которые отличны от наибольшего элемента не более чем на 10%.
Показать ответ
Ответ:
1Yuki2
06.10.2020 04:17
// PascalABC.NET 3.2, сборка 1425 от 22.04.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
var max:=a.Max;
Writeln('k=',a.Where(x->x>=0.9*max).Count)
end.
Пример
n= 20
9 1 -9 -8 -4 3 -5 -8 10 7 -9 1 -5 -4 0 -4 9 6 9 -8
k=4
0,0
(0 оценок)
Популярные вопросы: Информатика
rokivich
15.04.2022 09:55
Використовується модуль math , який містить стандартні константи та функції. Для роботи з цими константами й функціями необхідно підключити модуль в програму за до нструкції:...
z0mD
24.08.2022 05:49
Запишите десятичное число 5014, 11031 тремя различными в форме с плавающей запятой...
Ditroid
22.08.2022 19:06
История письменности формальными и естественными языками.сообщение на 1 лист а...
margaritakulak
06.12.2021 21:07
Для каких из приведенных чисел ЛОЖНО высказывание: а) НЕ (первая цифра числа чётная) И (последняя цифра числа нечётная)?1)123 2)258 3)347 4)409 5)607 6)709 7)801 б) НЕ (первая...
Klimka081098
08.04.2022 10:06
Использование модели черный ящик позволяет изучить?...
ANONIM235063
16.06.2022 04:39
Впервый год засеяно 20га. пшеницы. в последующие годы площадь увеличивали на 2% ежегодно. какова будет площадь через 12 лет нужно написать программу в паскале!...
19nadoeloikat1niki
16.06.2022 04:39
Чему равно арифметическое выражение? 9 div 3 9 mod 3 10 div 3 10 mod 3...
оченьнужно228300
16.06.2022 04:39
Даны два числа, пользователь вводит первое, затем второе, и выбирает действие /, *, + или -. на c++...
чсссвввввавшвневаа
11.12.2021 18:19
Задание 2. даны значения треугольников и его углов . в зависимости от углов необходимо составить программу, определяющую, является ли треугольник остроугольным, прямоугольный...
MaryLoveB
20.06.2022 10:59
Розробіть код, що визначає логічне значення виразу (a-b) =5, якщо а=9 і b=10....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-10,10); a.Println;
var max:=a.Max;
Writeln('k=',a.Where(x->x>=0.9*max).Count)
end.
Пример
n= 20
9 1 -9 -8 -4 3 -5 -8 10 7 -9 1 -5 -4 0 -4 9 6 9 -8
k=4