В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alsari
Alsari
08.06.2021 14:16 •  Информатика

Найдите ошибки, , не понимаю, что надо исправить сама : составить программу, которая вычисляет сумму тех элементов двумерного массива, номера строк и столбцов которых принадлежат соответственно непустым множествам s1 и s2. var a: array[1..20] of integer; n,m,i,j,k: byte; sm,b: integer; s1,s2: set of byte; begin randomize; repeat write('количество строк='); readln(m); until m in [1..10]; repeat write('количество столбцов='); readln(n); until n in [1..10]; writeln('исходная матрица: '); for i: =1 to m do begin for j: =1 to n do writeln; end; writeln; writeln('множество s1: '); s1: =[]; for i: =1 to m do begin b: =random(m)+1; s1: =s1+[b]; end; for i: =1 to m do if i in s1 then write(i,' '); writeln; writeln('множество s2: '); s2: =[]; for i: =1 to n do begin b: =random(n)+1; s2: =s2+[b]; end; for i: =1 to n do if i in s2 then write(i,' '); writeln; writeln; sm: =0; for i: =1 to m do for j: =1 to n do if(i in s1)and(j in s2) then sm: =sm+a[1..20]; write('сумма=',sm); readln end.

Показать ответ
Ответ:
DevilWoods
DevilWoods
04.10.2020 07:45
Четвёртая строка снизу:

if(i in s1)and(j in s2) then sm:=sm+a[1..20];

Вы к integer пытаетесь добавить array.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота