В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
кисуня17
кисуня17
29.01.2020 18:03 •  Информатика

найти ошибку в коде для программы код паскаля У вас на столе лежит N монет. Некоторые из них лежат вверх решкой, а
некоторые - гербом. Определите минимальное число монет, которые нужно
перевернуть, чтобы все монеты были повернуты вверх одной и той же стороной.

program coins;
var
n,i,s,a:longint;
begin
readln(n);
for i:=1 to n do
begin
readln(a);
if a=0 then
s:=s+1
end;
writeln(s);
end.

Показать ответ
Ответ:
Кара101
Кара101
26.03.2021 00:28

#include <bits/stdc++.h>

using namespace std;

int main()

{

   int n, k1 = 0,k2 = 0;

   cin >> n;

   int b = 0;

   vector<int> a;

   for(int i = 0; i < n; ++i){

       cin >> b;

       a.push_back(b);

   }

   for(int i = 0; i < a.size(); ++i)

       if(!(a.at(i)%2==0)){

           cout << a.at(i) << " ";

           k1++;

       }

   cout << endl;

   for(int i = 0; i < a.size(); ++i)

       if(a.at(i)%2==0){

           cout << a.at(i) << " ";

           k2++;

       }

   cout << endl;

   if(k1 > k2)

       cout << 3;

   else

       cout << 4;

   return 0;

}

0,0(0 оценок)
Ответ:
gabenew
gabenew
02.08.2022 21:27

могут использоваться:

ура ура

текст

Music

2 + 3(без точки в конце)

Объяснение:

Имя файла не должно содержать „<” (знак меньше), „>” (знак больше), „:” (двоеточие), „«” (двойные кавычки), „/” (слеш), „\” (обратный слеш), „|” (вертикальная черта), „?” (вопросительный знак), „*” (звездочка), а также не может заканчиваться точкой или пробелом. Файлы также нельзя называть зарезервированными именами устройств: CON, PRN, AUX, NUL, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, и LPT9.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота