В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Дурашка008
Дурашка008
06.03.2021 04:36 •  Информатика

найти ошибку в написании программы на си!В задаче нужно было вычислить величину скидки.Скидка в 3% предоставляется,если сумма покупки больше 500 рублей, в 5% - если сумма больше 1000 рублей, 8% при стоимости покупки свыше 1500 рублей! Входные данные: Сумма покупки.Пример вывода :Введите сумму покупки и

нажмите [Enter]

-> 640

Ваша скидка 3%

Сумма скидки: 19.20 руб.

Вот мое решение

#include

int main()

{

int S, P;

printf("Введите сумму\n");

scanf("%d", &S);

if S>500

{

P=3;

S=S/100*P;

printf("Ваша скидка %d\n", P);

printf("Сумма скидки %d\n", S);

end

}

else if (S>1000)

{

P=5;

S=S/100*P

printf("Ваша скидка %d\n", P);

printf("Сумма скидки %d\n", S);

end;

}

else if (S>1500)

{

P=8;

S=S/100*P

printf("Ваша скидка %d\n", P);

printf("Сумма скидки %d\n", S);

end;

if S<=500

printf("Вы ввели неверные данные %d\n");

return 0;

}

Показать ответ
Ответ:
ivan497
ivan497
11.12.2020 19:06

#include <stdio.h>

int main()

{

 int S, P;

 printf("Введите сумму\n");

 scanf("%d", &S);

 if (S > 1500)

 {

   P = 8;

   S = S / 100 * P;

   printf("Ваша скидка %d\n", P);

   printf("Сумма скидки %d\n", S);

 }

 else if (S > 1000)

 {

   P = 5;

   S = S / 100 * P;

   printf("Ваша скидка %d\n", P);

   printf("Сумма скидки %d\n", S);

 }

 else if (S > 500)

 {

   P = 3;

   S = S / 100 * P;

   printf("Ваша скидка %d\n", P);

   printf("Сумма скидки %d\n", S);

 }

 else

 {

   printf("Для вашей суммы не предусмотренна скидка\n");

 }

 return 0;

}

Объяснение:

Пропущен header, отсутствуют скобки после if, отсутствует ";", END??? Зачем?? Точно нужно было написать на "C"?

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота