В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alevtinatian
alevtinatian
13.07.2021 12:01 •  Информатика

Найти сумму положительных элементов вектора c[15]. составить программу в pascalabc

Показать ответ
Ответ:
elkenakate1221
elkenakate1221
03.10.2020 18:40
//Проверил. Да, равно.
//Pascal ABC.NET 3.1 сборка 1219

Const
 n=15;

Var
 ar:array[1..n] of integer;
 i,s:integer;
begin
randomize;
 writeln('Array:');
 for i:=1 to n do
  begin
   ar[i]:=random(-10,10);
   write(ar[i]:4);
   if ar[i]>0 then s:=s+ar[i];
  end;
 writeln;
 write('Result:',s);
end.

Пример работы программы:
Array:
   3  -7   0   9  -9   6  -1   0   1   0  -7   9  -9  -5  -8
Result:28
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота