В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kekit
Kekit
16.06.2020 06:55 •  Информатика

Найти все целые двузначные числа, кратные 9 и заканчиваются цифрой 3. Написать программу на языке Паскаль ВАС ОТ

Показать ответ
Ответ:
Mariiar
Mariiar
17.09.2022 11:18
Const n = 5;
var
  a: array [1..n] of integer;
  i,l,m,k: integer;
begin
  for i := 1 to n do read(a[i]);
  l := 1;
  while l < n do
    begin
    while (a[l] mod 2 = 0) and (l < n) do l := l + 1;
    if l < n then
      begin
      k := l;
      m := a[l];
      for i := l+1 to n do
        if a[i] mod 2 <> 0 then
        if a[i] > m then
          begin
          m := a[i];
          k := i
          end;
      a[k] := a[l];
      a[l] := m;
      l := l + 1
      end;
    end;
  for i := 1 to n do write(a[i],' ')
end.
0,0(0 оценок)
Ответ:
24vwyda
24vwyda
03.08.2020 13:02

1) Наиболее популярные MP3, AC3, MIDI, OGG, WAV

Прочие AA AAC AC3 (Dolby Digital) ADX AHX AIFF APE ASF AU[en] (SND) AUD DMF DTS DXD FLAC MIDI MMF (Yamaha SMAF) MOD MP1 MP2 MP3 MP4 MPC Ogg Vorbis Opus RA TTA VOC VOX[en] VQF WAV WMA XM

3) Наиболее популярные MP4, 3GP, AVI, MKV, VOB, MOV

Прочие ASF AVI (Audio Video Interleave) HDrip BIK (BinkVideo) FLV (Flash Video) Matroska (.mkv) MPEG-TS MXF (Material eXchange Format) Ogg (для Tarkin и Theora) QuickTime (.mov, .qt) RealMedia RIFF-AVI Smacker (*.smk) SWF (ShockWave File) VOB (DVD-Video File) WMV AVCHD (.mts) 3G2 3GP2 3GPP AVI_NEO_ DIVX DSM EVO F4V FLIC M2V HDMOV IFO M2P M2T M2TS M4V M1V MP4V MPV MPV2 MPV4 MTS RAM REC RM RMJ RMM RMS RMVB TP TRP MPE TTS VP6 WEBM

2)

- Подготовка или анализ. Просматривается исходный файл и подбирается наиболее оптимальный сжатия

- Сжатие.

* сокращается временная избыточность (кодируется только разностная информация, убираются повторяющиеся куски кадров, компенсация движения).

* сокращается пространственная избыточность путем исключения мелких деталей там где при просмотре сюжета это визуально не заметно.

* сокращается незначащая часть данных цветности (по сравнения с информацией яркости, цветовая (хроматическая) информация снижается в двое путем дискретизации)

- Квантование. Повышается информационная плотность результирующего цифрового потока путем выбора оптимального математического кода для его описания (похоже на архивирование)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота