В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
robertva693
robertva693
25.01.2020 15:45 •  Информатика

НЕ ПОЛУЧАЕТСЯ РЕШИТЬ! Напишите программу, которая находит кота.
Пользователь вводит строки до тех пор, пока он не введёт «СТОП». Программа выводит номер строки, на которой впервые был упомянут кот (в том же смысле, что и в предыдущей задаче), или -1 (минус один), если кот не был упомянут.

Формат ввода
Несколько строк.
Сигнал остановки — строка «СТОП».

Формат вывода
Одно число — номер первой строчки, в которой появился кот, или -1, если кота нет.

Пример
Ввод
Как устроен типичный фрукт:
кожура;
мякоть;
косточки.
СТОП
Вывод;
3

Показать ответ
Ответ:
gabiko82
gabiko82
25.11.2020 17:34

a = 0

b = 0

c = True

while True:

   v = input()

   a += 1

   if 'кот' in v.lower() and c:

       b = a

       c = False

   if 'стоп' in v.lower():

       break

if not b:

   b = -1

print(b)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота