В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
HappyGamerAND3000
HappyGamerAND3000
09.01.2020 12:01 •  Информатика

Не проходите мимо) нужно написать программу на с++ (консоль) .использовать двумерный вектор,а не обычный массив. дано динамичный двумерный массив (вектор) который заполняется случайными числами.и выводит их на экран.ищет максимальное число и удаляет строку в которой оно находиться и выводит на экран что осталось. пример : входные: 1 2 3 4 5 6 7 8 9 выходные: 1 2 3 4 5 6 буду за решение)

Показать ответ
Ответ:
Rostislav200353
Rostislav200353
02.09.2020 01:53
//Microsoft (R) C/C++ Optimizing Compiler Version 19.00.23506 for x64

#include <vector>
#include <array>
#include <iostream>
#include <algorithm>
#include <utility>
#include <random>
#include <iterator>
using namespace std;

int main()
{
    mt19937 gen{ random_device()() };
    uniform_int_distribution<> uid(1, 100);
    vector<vector<int>> v2d(3, vector<int>(3));
    int max_i;
    for_each(v2d.begin(), v2d.end(), [&max_i, &uid, &gen](vector<int>& v) {
            generate(v.begin(), v.end(), [&uid, &gen]() { return uid(gen); });
            max_i = max(*max_element(v.begin(), v.end()), max_i);
        });
    cout << endl;
    v2d.erase(remove_if(v2d.begin(), v2d.end(), [&max_i](vector<int>& v) {
        return find(v.begin(), v.end(), max_i) != v.end();
    }), v2d.end());
    for (const auto& i : v2d)
    {
        copy(i.begin(), i.end(), ostream_iterator<int>(cout, " "));
        cout << endl;
    }
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота