Недавно решил написать программу на пайтон которая спрашивает у пользователя картинку и ставит её на рабочий стол но моя программа просто ставит обои кстати вот код import ctypes
import os
SPI_SETDESKWALLPAPER = 20
ctypes.windll.user32.SystemParametersInfoA(SPI_SETDESKWALLPAPER, 0,'img.png', 3)
не подскажите как доработать программу
n=5;
Var
ar:array[1..n] of integer;
ar2:array[1..n] of integer;
i,k:integer;
function prost(a:integer):boolean;
var i:integer;
b:boolean;
begin
b:=true;
for i:=2 to a div 2 do
if a mod i=0 then
begin;
b:=false;
break;
end;
if a=1 then b:=false;
prost:=b;
end;
begin;
randomize;
k:=0;
for i:=1 to n do
begin;
ar[i]:=random(101);
write(ar[i]:4);
end;
writeln;
for i:=1 to n do
if prost(ar[i]) then
begin;
inc(k);
ar2[k]:=ar[i];
write(ar2[k]:4);
end;
end.
Реальная программа, выполняемая ЭВМ (электронная вычислительная машина), представляет собой последовательность единиц и нулей, которая хранится в памяти машины. Эту цепочку единиц и нулей (бит) называют машинным языком.