В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Необходимо было написать программу, которая позволяет найти наименьшее
число, большее 500, кратное 17 и вывести его на экран.
Программист торопился и написал программу с ошибками. Укажите строки,
в которых допущены ошибки.
Var x: integer;
Begin
x:= 500;
Repeat o
x := х – 1;
Until x mod 17 <> 0
Writeln (х);
End.​

Показать ответ
Ответ:
13022010
13022010
13.10.2020 22:11

Var x: integer;

Begin

x:= 500;

Repeat o  //здесь непонятный символ o (должно быть: Repeat)

x := х – 1;   //здесь должно быть наоборот: к x надо прибавлять 1, так как надо найти число большее 500 (должно быть: x:= x + 1;)

Until x mod 17 <> 0   //здесь ошибка в том, что цикл repeat остановится когда число, деленное на 17, будет иметь остаток, а надо остановить тогда, когда при делении числа на 17 будет 0, то есть делится на 17 без остатка(должно быть: Until x mod 17 = 0;)

Writeln (х);

End.​

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота