В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
FadePLAY
FadePLAY
23.02.2021 23:48 •  Информатика

Необходимо написать программу, которая находит минимальный элемент матрицы и ставит его на место первого элемента матрицы(то есть в левый верхний угол)

Показать ответ
Ответ:
Diyora2007
Diyora2007
10.10.2020 07:22

const N=5;

var a:array [1..N,1..N] of integer;

i,j,min:integer;

begin

 randomize;

 for i:=1 to N do  

   begin

     for j:=1 to N do

       begin

         a[i,j]:=random(21)-10;

         write(a[i,j]:4);

       end;

     writeln;

   end;

   writeln;

 min:=a[1,1];

 for i:=1 to N do

   for j:=1 to N do

     if a[i,j]<min then

       min:=a[i,j];

 if min<>a[1,1] then a[1,1]:=min;

 for i:=1 to N do

   begin

     for j:=1 to N do

       write(a[i,j]:4);

     writeln;

   end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота