В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
nastya190420
nastya190420
15.09.2020 20:33 •  Информатика

Необходимо написать программу, которая проверяет, знаете ли вы таблицу умножения. Программа выводит на экран пример, ответ на который должен ввести пользователь. Программа должна вывести на экран, верно ли ответил пользователь, и показать правильный результат, если пользователь ответил неверно.
Генерируйте пример с генератора случайных чисел (random, randint)
Таблица умножения включает в себя числа от 1 до 9
В программе должно быть ветвление if

Показать ответ
Ответ:
dashko4etckowa
dashko4etckowa
27.08.2020 23:57

import random

while True:

       a = random.randint(1, 9)

       b = random.randint(1, 9)

       i = 0

       while True:

               try:

                       print("%dx%d=" % (a, b), end="")

                       i = int(input())

               except ValueError:

                       print("Введите число!")

               else:

                       break

       rightAnswer = a * b

       if i == rightAnswer:

               print("Верно!\n")

       else:

               print("Неверно! Верный ответ: %d\n" % rightAnswer)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота