В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Мистер9900
Мистер9900
14.07.2020 22:44 •  Информатика

Ниже записана программа. получив на вход число x эта программа печатает 2 числа укажите наибольшее из таких чисел X при вводе которых алгоритм печатает сначала 3 а потом 7
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:= L+1;
M:= M+ x mod 10;
x:= x div 10;
end;
writeln(L); write(m);
end.

Показать ответ
Ответ:
Nemuverus
Nemuverus
06.08.2020 20:24

При выполнении алгоритма для получения ответа необходимо трёхзначное число с суммой цифр 7.

Самым большим числом будет 700.

(результат выполнения в изображении)


Ниже записана программа. получив на вход число x эта программа печатает 2 числа укажите наибольшее и
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота