В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Ниже записана программа. получив на вход число x, она печатает два числа. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 10. var x, l, m: integer; begin readln(x); l: =0; m: =0; while x > 0 do begin l: =l+1; if (m < x) and (x mod 2 = 1) then begin m: = (x mod 10) * 2; end; x: = x div 10; end; writeln(l); write(m); end.

Показать ответ
Ответ:
404678
404678
07.10.2020 13:14
 L=2 -   количество цифр в числе Х
М=10 - (последняя цифра числа Х)*2>
                                                        (последняя цифра числа Х)=10:2=5
мах Х=95              ответ 95
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота