В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
romashka1899
romashka1899
08.08.2020 03:08 •  Информатика

НУЖНА Дан целочисленный массив из 30 элементов. Элементы массива могут принимать натуральные значения от 1 до 10000 включительно. Составить программу
а) которая находит произведение элементов массива, меньших 100 и при этом имеющих
нечетные значения
б) которая находит минимальный элемент и заменяет каждый элемент массива, меньший 100 и
имеющий нечетное значение на минимальный элемент
в) упорядочить массив по возрастанию.

Показать ответ
Ответ:
Boxing12474
Boxing12474
07.04.2022 04:25
Ну во-первых:
Скорость. Бумажное Письмо по России идет до 2х а то и более недель. НЕ говоря уже о письмах за границу и о стоимости отправки одного письма. А электронное письмо. Нажал и через секунду оно доставлено в любую точку планеты. БЕСПЛАТНО. Отправить в электронном письме можно музыку, фильмы, фото, одним словом любой файл. А в обычном??? Попробуйте отправить с бумажным письмом любимую музыку или фильм? Надо вложить в письмо диск с музыкой или фильмом. Единственный недостаток электронного письма-не можешь отправить деньги по нему. Но щас это можно сделать через сторонние сервера. Что касаемо звонка Вы можете слышать голос, однако качество связи не всегда хорошее. Да и позвоните в Америку, сколько с Вас снимут за минуту разговора? А отправили письмо- и бесплатно и написал не спеша все что хотел. Рассказал все сплетни и пр.)
0,0(0 оценок)
Ответ:
lugmar3
lugmar3
23.09.2022 21:24
var
  y, x, a, xn, xk, dx, sum, multiplNegative: real; 
  countNegative: integer; 
  j, m, f: real;

begin
  write('a --> '); 
  Read(a); 
  write(' xn --> '); 
  Read(xn); 
  write(' xk --> '); 
  Read(xk); 
  write(' dx --> '); 
  Read(dx);
  sum := 0; 
  multiplNegative := 1; 
  countNegative := 0; 
  x := xn;
  while (x <= xk) do 
  begin
    if (a + x < 0) then begin
      f := (a + x) * -1; 
      f := ln(f) * (-1); 
      j := Round(abs(a - sqr(x)) * f * 100000) / 100000; 
    end 
    else 
      j := Round(abs(a - sqr(x)) * ln(a + x) * 100000) / 100000; 
    m := Power(sqr(x), 1 / 3) + Power(a, 1 / 5); 
    if j < 0 then begin
      j := j * (-1); 
      j := Power(j, 1 / 3); 
      j := j * (-1); 
    end 
    else 
      j := Power(j, 1 / 3);
    y := Round(j / m * 100000) / 100000; 
    write('x= ', x:5:3, ' '); 
    writeln('y= ', y:7:5); 
    if y < 0 then 
    begin
      sum := sum + y; 
      multiplNegative := multiplNegative * y; 
      inc(countNegative); 
    end; 
    x := x + dx; 
  end; 
  writeln; 
  writeln(' y = ', countNegative); 
  writeln('y = ', sum:7:5); 
  writeln(' y = ', multiplNegative:7:5);
  Readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота