НУЖНА Напишите программу для решения следующей задачи:
Дано натуральное число. Требуется определить, является ли год с данным номером високосным. Если год является високосным, то выведите YES, иначе выведите NO. Напомним, что в соответствии с григорианским календарем, год является високосным, если его номер кратен 4, но не кратен 100, а также, если он кратен 400.
Программа получает на вход одно число – год.
Экран выполнения программы:
Введите год 2011
NO
Алгоритм выполнения программы:
Ввод переменной, обозначающей год
Проверка переменой на кратность 4-м и на кратность 100-м
В случае истинности проверки, печать слова YES
Алтернативная проверка переменой на кратность 400-м
В случае истинности проверки, печать слова YES
В противном случае печать слова NO
Язык: Python
a,b,c,p,s:real;
m:integer;
begin
repeat
writeln('a,b,c &');
readln(a,b,c); {Вводим стороны до тех пор пока не выполнится условие сущ треуг}
until (a<b+c)and(b<a+c)and(c<a+b);
writeln('площадь - введите 1 или периметр -2 ?');
{выбираем что считать, если площадь, то вводим 1, периметр - 2}
readln(m);
case m of
1:
begin
p:=(a+b+c)/2;
writeln('S = ',sqrt(p*(p-a)*(p-b)*(p-c))); {вывод площади}
end;
2:writeln(a+b+c); {вывод периметра}
end;
end.
программа 2 Нахождение суммы элементов одномерного массива
const
n=10;
Var
a:array[1..n]of integer;
i,s:integer;
begin
for i:=1 to n do
begin
a[i]:=random(100); {заполнение массива случайными числами [0.100)}
write(a[i]:4); {выводим на экран массив}
s:=s+a[i]; {считаем сумму}
end;
writeln;
writeln('S= ',s); {выводим сумму}
end.
#include <iostream>
using namespace std;
int main() {
const char* s = "one two three four five six seven";
const char* w = 0;
int max_size = 0;
int word_size = 0;
for (int i = 0; s[i]; i++) {
if (s[i] != ' ') {
word_size++;;
} else if ((s[i] == ' ') || !s[i + 1]) {
if (word_size > max_size) {
max_size = word_size;
w = s + i - word_size;
}
word_size = 0;
}
}
for (int i = 0; i < max_size; i++) {
std::cout << w[i];
}
std::cout << "\n";
return 0;
}