В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Danila1367
Danila1367
07.05.2021 07:51 •  Информатика

нужна Не будьте равнодушными выполнить любое задание из 9
написать программу в паскале

Показать ответ
Ответ:
Nastya21724
Nastya21724
27.04.2023 14:37

// A)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var Count := 2;

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

   Count += 1

 until Count = 40;

 

 Write(f2)

end.

// B)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var m := ReadlnInteger();

 

 repeat

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 > m;

 

 Write(f2)

end.

// C)

begin

 var f1 := BigInteger(1);

 var f2 := BigInteger(1);

 var S := f1;

 

 repeat

   S += f2;

   var f := BigInteger(f1 + f2);

   f1 := f2;

   f2 := f;

 until f2 >= 1000;

 

 Write(S)

end.

0,0(0 оценок)
Ответ:
selenagulya2002
selenagulya2002
17.08.2022 03:01

Program Pr1;
uses crt;
var fl1,fl2:text;
i,n,v,a,b:integer;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
v:=0;
for i:=1 to 1000000 do begin
if i>=10 then begin
a:=i div 10;
b:=i mod 10;
if (a mod 2<>0) and (b mod 2<>0) then v:=v{?} 1; {здесь либо пропущен знак либо v1-новая переменная не перечисленная в списке описания переменных}
end
else if i mod 2<>0 then v:=v 1;{здесь тоже самое}
if v=n then break;
end;
rewrite(fl2);
writeln(fl2,v);
close(fl1);
close(fl2);
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота