Нужна ! нужно написать программу в pascalabc, а точнее решить олимпиадную :
дано 5 натуральных чисел, не превышающих 2 000 000 000. вывести значение того из них, которое ближе к их среднему арифметическому. в случае наличия вариантов правильных ответов вывести меньший вариант.
пример:
входной файл 6 2 8 1 10
выходной файл 6
пояснение к примеру: среднее арифметическое равно (1+2+6+8+10)/5=5.4. минимальное значение модуля разности дает 6(0.6).
Кулер для процессора Thermalright True Spirit 140
Мат. плата Socket1155 ASUS P8Z77-V
Модуль памяти 2x8ГБ DDR3 SDRAM Geil Evo Two GET316GB1600C9DC (PC12800, 1600МГц, CL9)
Жесткий диск 2000ГБ Seagate Barracuda Green ST2000DL003
Накопитель SSD 120ГБ 2.5 OCZ "Vertex 3 VTX3-25SAT3-120G
Видеокарта GeForce GTX 670 2048МБ GIGABYTE GV-N670OC-2GD
Корпус Miditower Zalman Z9 Plus
Блок питания 720Вт Cooler Master Silent Pro M2
45000 руб.
P.S. Если вместо GTX670 взять GTX680, то как раз под 50 000 выйдет. Но по моему этоу уже будет лишней тратой денег.
вот программа на С++:
#include <iostream>
using namespace std;
int main()
{
setlocale(0, "Russian");
int a, b, c;
cout << "Введите 3 целых числа: " << endl;
cin >> a >> b >> c;
if(a>b && a>c)
{
cout << "Максимальное число = " << a << endl;
}
if(b>a && b>c)
{
cout << "Максимальное число = " << b << endl;
}
if(c>b && c>a)
{
cout << "Максимальное число = " << c << endl;
}
cin >> a;
return 0;
}