В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Лейла1994
Лейла1994
31.07.2021 04:14 •  Информатика

Нужна с массивом. известно количество учащихся в каждом из к классов школ. составить программу, которая определяет, сколько всего учащихся обучается в тех классах школы, в которых меньше, чем 30 человек. заранее

Показать ответ
Ответ:
Рома2043
Рома2043
10.08.2020 22:16
Var sum{кол-во учащихся, ответ},k,i:integer;
      a:array[1..1000] of integer;
begin
readln(k);  
sum:=0;
For i:=1 to k do
  readln(a[i]);
For i:=1 to k do
   If a[i]<30 then    {Если кол-во учащихся в классе <30 то прибавляем}
      sum:=sum+30;
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота