В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Fukci
Fukci
02.03.2021 17:49 •  Информатика

НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то есть недоработка и они работают неправильно. Компилятор никакой ошибки не выводит, поэтому не могу разобраться в чём дело...
Прикрепляю задания, свои коды и скрины работы прог:

1)Составить программу на Паскале, которая удалит все буквы «о» из текста, который состоит из 6 слов. Текст нужно придумать самостоятельно.

Мой код:

program udalenye;
var s, s1: string;
i: byte;
begin
writeln('введите текст, состоящий из 6 слов');
readln(s);
writeln('исходная строка: ', s);
s1:='';
for i:=1 to length(s) do
if (s[i]<>'о') then s1:=s1+s[i];
writeln('строка после удаления всех букв "о": ', s1);
end.

2)Определить, сколько раз в тексте встречается буква «и».

В качестве входных данных введите текст, состоящий из Ваших фамилии, имени и отчества.

Мой код:

program bukva;
var s: string;
i, k: integer;
len: byte;
begin
k:=0;
writeln('введите имя, фамилию и отчество');
readln(s);
len:=length(s);
for i:=1 to len do
begin
if s[i]='и' then k:=k+1;
end;
writeln('буква "и" встречается в тексте ', k, ' раза(раз)');
end.


НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то
НУЖНА С ПАСКАЛЬ Ребят, подскажите, кто знает: написала 2 проги в паскаль(самостоятельно), но где-то

Показать ответ
Ответ:
alekseywindas
alekseywindas
10.05.2022 15:54

Представление.

Объяснение:

   В данном случае не хватает сведений для того, чтобы с уверенностью ответить на данный вопрос. Можно с уверенностью сказать, что номер уже имеется на каком-то источнике информации, то есть это не "сбор". Также это не "хранение", так-как информация с одного носителя в конечном итоге перемещается на другой. Также это не является "передачей" информации в полном смысле этого словосочетания, так-как передача осуществляется без преобразования информации.

   Соответственно запись номера в телефонную книжку - представление информации из того, в каком виде эта информация поступила к записывающему в текст.  

0,0(0 оценок)
Ответ:
nastya632011
nastya632011
06.04.2021 17:42
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота